Cisco IOS CLI | Cisco NX-OS CLI |
---|---|
Configuring a Routed Interface |
interface gigabitethernet 1/1
ip address 192.168.1.1 255.255.255.0 no shutdown | interface ethernet 1/1
ip address 192.168.1.1/24 no shutdown |
---|
Configuring a Switched Interface (VLAN 10) |
vlan 10
switchport switchport mode access switchport access vlan 10 no shutdown | vlan 10
switchport switchport mode access switchport access vlan 10 no shutdown |
---|
Configuring a Switched Virtual Interface (SVI) |
Cisco IOS Software does not have the ability to enable or disable SVI interfaces using the feature command.
ip address 192.168.1.1 255.255.255.0 no shutdown | feature interface-vlan
ip address 192.168.1.1./24 no shutdown |
---|
Configuring a Switched Trunk Interface |
interface GigabitEthernet 1/1
switchport switchport trunk encapsulation dot1q switchport trunk native vlan 2 switchport trunk allowed vlan 10,20 switchport mode trunk no shutdown | interface ethernet 1/1
switchport mode trunk switchport trunk allowed vlan 10,20 switchport trunk native vlan 2 no shutdown |
---|
Configuring a Routed Trunk Sub-Interface |
interface gigabitethernet 1/1
no switchport no shutdown
interface gigabitethernet1/1.10 encapsulation dot1Q 10 ip address 192.168.1.1 255.255.255.0 no shutdown | interface ethernet 1/1
no switchport no shutdown
encapsulation dot1q 10 ip address 192.168.1.1/24 no shutdown |
---|---|
Configuring a Loopback Interface |
interface loopback 1
ip address 192.168.1.1 255.255.255.255 no shutdown | interface loopback 1
ip address 192.168.1.1/32 no shutdown |
---|
Configuring a Tunnel Interface |
Cisco IOS Software does not have the ability to enable or disable Tunnel interfaces using the feature command.
ip address 192.168.1.1 255.255.255.0 tunnel source 172.16.1.1 tunnel destination 172.16.2.1 no shutdown | feature tunnel
ip address 192.168.1.1/24 tunnel source 172.16.1.1 tunnel destination 172.16.2.1 no shutdown |
---|
Configuring an Interface Description | |
interface gigabitethernet 1/1
description Test Interface | interface ethernet 1/1
description Test Interface |
---|
Configuring Jumbo Frames | |
interface gigabitethernet 1/1
mtu 9216 | interface ethernet 1/1
mtu 9216 |
---|
Configuring Multiple Interfaces (Examples) | |
interface range gigabitethernet 1/1-2
or interface range gigabitethernet 1/1, gigabitethernet 2/1 | interface ethernet 1/1-2
or interface ethernet 1/1, ethernet 2/1 |
---|
Configuring Port Profiles | |
Cisco IOS Software does not have the ability to configure port profiles. | port-profile type ethernet Email-Template
switchport switchport access vlan 10 spanning-tree port type edge no shutdown description Email Server Port state enabled
inherit port-profile Email-Template |
---|
TDR Cable Diagnostics | |
test cable-diagnostics tdr interface gigabitethernet 1/1 | test cable-diagnostics tdr interface etherent 1/1 |
---|
Configuring the Interface Locator-LED (Beacon) | |
Cisco IOS Software does not have the ability to enable a located-led per interface. | interface ethernet 1/1
beacon |
---|
Configuring a Nexus 2000(FEX) Host Interface | |
Cisco IOS Software does not have the ability to connect a Nexus 2000(FEX). | interface ethernet 101/1/1 |
---|
Verification Command Comparison
The following table lists some useful show commands for verifying the status and troubleshooting an interface.
Cisco NX-OS Interface | Cisco IOS Software Interface | Command Description |
---|---|---|
show interface | show interface | Displays the status and statistics for all interfaces or a specific interface |
show interface ethernet <x/x/x> | - | Displays the status and statistics for a FEX host interface |
show interface ethernet <x/x> cable-diagnostics tdr | show cable-diagnostics tdr interface type <x/x> | Displays TDR test results |
show interface brief | - | Displays a brief list of the interfaces (type, mode, status, speed, MTU) |
show interface capabilities | show interface capabilities | Displays interface capabilities |
show interface counters | show interface counters | Displays interface counters (input/output unicast, multicast & broadcast) |
show interface debounce | show interface debounce | Displays the de-bounce status and time in ms for all interfaces |
show interface description | show interface description | Displays all interfaces with configured descriptions |
show interface ethernet | show interface ethernet | Displays status and statistics for a specific interface |
show interface fex-fabric | - | Displays FEX fabric interface status |
show interface flowcontrol | show interface flowcontrol | Displays Flow Control (802.1p) status and state for all interfaces |
show interface loopback | show interface loopback | Displays status and statistics for a specific loopback interface |
show interface mac-address | - | Displays all interfaces and their associated MAC Addresses |
show interface mgmt | - | Displays status and statistics for the management interface located on the supervisor |
show interface port-channel | show interface port-channel | Displays status and statistics for a specific port-channel |
show interface priority-flow-control | - | Displays PFC information |
show interface pruning | show interface pruning | Displays trunk interfaces VTP pruning information |
show interface snmp-ifindex | - | Displays SNMP interface index |
show interface status | show interface status | Displays all interfaces and their current status |
show interface switchport | show interface switchport | Displays a list of all interfaces that are configured as switchports |
show interface transceiver | show interface transceiver | Displays a list of all interfaces and optic information (calibrations, details) |
show interface trunk | show interface trunk | Displays a list of all interfaces configured as trunks |
show interface tunnel <#> | show interface tunnel <#> | Displays status and statistics for a specific tunnel interface |
show interface vlan <#> | show interface vlan <#> | Displays status and statistics for a specific VLAN interface |
- | - | - |
show port-profile | - | Displays all port profile information |
show port-profile brief | - | Displays brief port profile information |
show port-profile expand-interface | - | Displays active profile configuration applied to an interface |
show port-profile name | - | Displays specific port profile |
show port-profile sync-status | - | Displays interfaces out of sync with port profiles |
show port-profile usage | - | Displays interfaces inherited to a port profile |
No comments:
Post a Comment