Wednesday, June 17, 2015

OSPF NX-OS & IOS CLI

Cisco IOS CLI Cisco NX-OS CLI
Enabling the OSPF Feature
Cisco IOS Software does not have the ability to enable or disable OSPF. feature ospf
Configuring an OSPF Instance and Router ID
router ospf 10

router-id 192.168.1.1

router ospf 10

router-id 192.168.1.1

Associating a Network with an OSPF Instance and Area
router ospf 10

network 192.168.1.0 0.0.0.255 area 1

interface Ethernet2/1

ip address 192.168.10.1/24

ip router ospf 10 area 1

Configuring a Passive Interface
router ospf 10

passive-interface GigabitEthernet2/1

network 192.168.1.0 0.0.0.255 area 1

interface Ethernet2/1

ip address 192.168.11.1/24

ip ospf passive-interface

ip router ospf 10 area 0

Configuring Interface Authentication (MD5)
interface GigabitEthernet2/1

ip address 192.168.10.1 255.255.255.0

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 cisco123

interface Ethernet2/1

ip address 192.168.10.1/24

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 3 a667d47acc18ea6b

ip router ospf 10 area 1

Configuring a Stub Area with the no summary Option
router ospf 10

area 2 stub no-summary

router ospf 10

area 2 stub no-summary

Creating a Not-So-Stubby Area (NSSA) and Generating a Default Route
router ospf 10

area 3 nssa default-information-originate

router ospf 10

area 3 nssa default-information-originate

Configuring Inter-Area and External Summarization
router ospf 10

area 0 range 159.142.0.0 255.255.0.0 summary-address 172.16.0.0 255.255.0.0

router ospf 10

area 0 range 159.142.0.0/16 summary-address 172.16.0.0/16

Generating a Default Route (Conditional)
router ospf 10

default-information originate

router ospf 10

default-information originate

Generating a Maximum Metric (Max-Metric) Value
router ospf 10

max-metric router-lsa

router ospf 10

max-metric router-lsa

Configuring Route Redistribution (Permit all Static Routes)
router ospf 10

redistribute static subnets

router ospf 10

redistribute static route-map static-to-ospf


route-map static-to-ospf permit 10

Configuring a VRF Instance for OSPF Routing
router ospf 10 vrf customer-a router ospf 10

vrf customer-a



Verification Command Comparison

The following table compares some useful show commands for verifying and troubleshooting an OSPFv2 network configuration.


Cisco NX-OS OSPFv2 Cisco IOS Software OSPFv2 Command Description
show ip ospf show ip ospf Displays information for all OSPF instances
show ip ospf <instance> show ip ospf <#> Displays information for a specific OSPF instance
show ip ospf border-routers show ip ospf border-routers Displays a list of border routers
show ip ospf database show ip ospf database Displays OSPF database information
show ip ospf interface show ip ospf interface Displays all OSPF enabled interfaces and associated status information
show ip ospf interface brief show ip ospf interface brief Displays a brief list and status of OSPF enabled interfaces
show ip ospf interface detail - Displays additional packet statistics for each interface
show ip ospf lsa-content-changed-list - Displays the LSA's that changed content
show ip ospf memory - Displays the memory allocated for OSPF
show ip ospf neighbors show ip ospf neighbor Displays neighbor-specific information
show ip ospf neighbors detail show ip ospf neighbor detail Displays details for each OSPF neighbor
show ip ospf neighbors summary - Displays summary information and packet statistics for each OSPF neighbor
show ip ospf policy statistics - Displays redistribution statistics for a specified protocol
show ip ospf request-list show ip ospf request-list Displays a list of link-state advertisements (LSAs) that have been requested
show ip ospf retransmission-list show ip ospf retransmission-list Displays a list of the link-state retransmission list
show ip ospf route - Displays all routes learned through OSPF
show ip ospf statistics show ip ospf statistics Displays OSPF LSA statistics
show ip ospf summary-address show ip ospf summary-address Displays OSPF summarized networks
show ip ospf traffic show ip ospf traffic Displays OSPF related packet counters
show ip ospf virtual-links show ip ospf virtual-links Displays OSPF virtual links
show ip ospf vrf - Displays information for a specified OSPF VRF instance


No comments:

Post a Comment